Canvas Medical - Reports of faxing delays >1 hour – Incident details

Reports of faxing delays >1 hour

Resolved
Operational
Started 18 days agoLasted about 4 hours

Affected

Faxing

Degraded performance from 9:23 PM to 1:24 AM

Updates
  • Resolved
    Resolved

    All faxes have processed, we will continue to monitor for future reports.

  • Investigating
    Investigating

    We are getting reports of outgoing faxes being delayed >1 hour. We have a case open with Sfax and will update as we receive updates.