Canvas Medical - Background Jobs and Scheduled Tasks System Outage – Incident details

Background Jobs and Scheduled Tasks System Outage

Resolved
Major outage
Started 21 days agoLasted about 3 hours
Updates
  • Resolved
    Resolved

    All pending background tasks have been processed successfully. The service is now operating at normal capacity with no remaining backlog. We will continue to monitor system health closely.

  • Monitoring
    Monitoring

    Our background queue database reached a critical memory threshold, we scaled up its resources appropriately and are monitoring the backlog of background jobs now

  • Investigating
    Investigating

    We’re currently investigating an issue affecting background jobs (e.g., plugin cron tasks, appointment reminders, faxing updated, automated invoicing, lab polling, etc). Our team is monitoring system health while we work toward a fix.