Started 8 months agoNovember 19, 2025Lasted about 4 hoursNovember 19, 202512:083:46 AMUTC
Affected
Web Application
Degraded performance from 12:08 AM to 3:46 AM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
We implemented a fix and are currently monitoring the result.
Identified
UTC
Identified
UTC
We have also identified an issue with logging in (regardless of MFA settings), if on a previous release.
We have identified a fix for both login issues and are in the process of deploying these fixes.
Investigating
UTC
Investigating
UTC
We’ve identified a login issue to Canvas Settings/Admin affecting users with Multi-Factor Authentication (MFA) after our most recent release. We're currently implementing a fix. Users without MFA are unaffected.