Canvas Medical Performance Alert - Outbound Texting

Resolved
Degraded performance
Started 10 months ago Lasted 22 days

Affected

Patient Messaging
Updates
  • Resolved
    Resolved

    We’re pleased to announce the issue affecting outbound texting in Canvas has been resolved. Thank you for your patience. If you’re still experiencing issues, please reach out to your Customer Success associate or support@canvasmedical.com

  • Monitoring
    Monitoring

    Our outgoing text messages are no longer being blocked by the phone carriers. We will continue to monitor deliverability in Twilio to confirm that the issue is fully resolved. We appreciate your patience, and we will update you further as soon as we can.

  • Identified
    Update

    Our Brand registration was successful as of this morning and we have since registered all of our associated numbers. We are now waiting on our campaign approval. We will continue to provide updates as they become available. Please reach out to your Customer Success Associate or support@canvasmedical.com with any questions or concerns.

  • Identified
    Identified

    We’ve discovered an issue impacting Canvas's outbound texting capabilities through Twilio.

    A new regulation went into effect on July 5, 2023, requiring that all standard 10-digit long code phone numbers used for SMS, be registered to an approved campaign under a registered brand. Unfortunately, Canvas’s registration is still pending. Messages from unregistered numbers are subject to filtering by the phone carriers, meaning that our outbound SMS messages are being intermittently blocked across all phone carriers, with increasing frequency. We are working with Twilio to expedite our registration.

    Impacted customers (those utilizing our Twilio integration) have been contacted directly. We will be providing regular reports of impacted messages until this has been resolved. We know these issues are disruptive to your work, and we apologize for the inconvenience. Thank you for your patience.