Canvas Medical - Google Cloud Platform Outage – Incident details

Google Cloud Platform Outage

Resolved
Degraded performance
Started about 2 months agoLasted about 18 hours

Affected

Faxing

Degraded performance from 7:52 PM to 2:16 PM

Updates
  • Resolved
    Resolved

    Google has reported that all services are fully restored as of approximately 6/12/25 930pm ET

  • Identified
    Identified

    Google Cloud Platform (GCP) is currently experiencing interrupted service impacting a variety of services. Canvas users have reported an interruption in Faxing and Google Calendar functionality. Google has identified the issue and are working to resolve. You can additionally review status updates directly from Google here.